Crew is experiencing an issue sending and receiving messages.

Major incident Crew App
2019-01-28 19:00 UTC · 5 hours, 59 minutes

Updates

Resolved

The issue has been resolved and all services are back to normal.

January 29, 2019 · 00:59 UTC
Investigating

We are investigating the issue with message sends and people not receiving messages and inability to connect.

January 28, 2019 · 19:52 UTC

← Back