Investigating performance issues

Minor Incident Crew App
42 minutes

Update

Resolved

The fix that was deployed to our servers has resolved any delays to processing time.

March 27th, 2019 at 18:40 UTC
Investigating

The root cause has been identified. An issue with one of our non-critical service providers is causing processing delays and a change has been rolled out to address the issue.

March 27th, 2019 at 18:26 UTC
Investigating

We are currently seeing escalated message delivery times. Our engineering team is investigating the root cause.

March 27th, 2019 at 17:59 UTC