Message delivery delays

Minor incident Crew App
2019-04-16 18:43 UTC · 20 minutes, 36 seconds

Updates

Resolved

The root of issue was discovered and has been resolved. All functionality should now be back to normal

April 16, 2019 · 19:04 UTC
Investigating

We are investigating reports of slow message delivery.

April 16, 2019 · 18:44 UTC

← Back