Investigating Client Connection issues

Minor Incident Crew App
38 minutes

Update

Resolved

Client connectivity issues have been resolved.

May 5th, 2019 at 00:11 UTC
Investigating

We are currently experiencing intermittent connectivity issues between some of our users and our servers. Our engineers are investigating.

May 4th, 2019 at 23:34 UTC