Connectivity Issues
Minor incident
Crew App
2019-05-08 12:50 UTC
·
39 minutes
Updates
Resolved
November 4, 2021 · 15:24 UTC
We have restarted some misbehaving servers and has seemed to clear up the issue. Our engineers are still investigating deeper into the root cause of the issue.
Investigating
November 4, 2021 · 15:24 UTC
There have been reports of connectivity issues to our client applications.
← Back