Connectivity Issues

Minor incident Crew App
2019-05-11 19:13 UTC · 10 minutes

Updates

Resolved

The root of the issue was discovered and is now resolved.

November 4, 2021 · 15:24 UTC
Issue

There are reports of connectivity issues that our engineering team is looking into

November 4, 2021 · 15:24 UTC

← Back