Connectivity Issues

Minor incident Crew App
2 hours, 1 minute, 46 seconds

Updates

Resolved

All issues are resolved at this time.

May 22, 2019 · 21:06 UTC
Monitoring

The root cause of connectivity issues has been identified and fixes have been made. We are continuing to monitor our systems to make sure no other issues arise.

May 22, 2019 · 19:25 UTC
Resolved

All issues are resolved at this time.

May 22, 2019 · 19:05 UTC

← Back