Connectivity Issues

Major incident Crew App
2019-06-01 11:58 UTC · 2 hours, 28 minutes

Updates

Resolved

A certificate utilized for communication with one of our internal services expired and prevented clients from being able to sync new content to their devices. The issue has been resolved.

November 4, 2021 · 15:24 UTC
Issue

Clients are reporting connectivity issues with our service.

November 4, 2021 · 15:24 UTC

← Back