Crew is experiencing an issue sending and receiving messages.

Major incident Crew App
2020-09-25 19:15 UTC · 10 hours, 43 minutes, 25 seconds

Updates

Resolved

The issue has been resolved and all service are back to normal.

September 26, 2020 · 05:58 UTC
Investigating

We have identified the core issue and systems are starting to recover slowly.

September 26, 2020 · 00:55 UTC
Update

We are currently seeing escalated message delivery times. Our engineering team is investigating the root cause.

September 25, 2020 · 22:44 UTC
Monitoring

The root cause of the issue has been discovered and we are now monitoring an update that should resolve the issue.

September 25, 2020 · 20:05 UTC
Issue

Crew is experiencing a delay in sending and receiving messages.

September 25, 2020 · 19:34 UTC

← Back