Connectivity Issues

Minor incident Crew App
2020-10-30 15:06 UTC · 2 hours, 47 minutes, 14 seconds

Updates

Resolved

All issues are resolved at this time.

October 30, 2020 · 17:53 UTC
Issue

We are currently experiencing intermittent connectivity issues between some of our users and our servers. Our engineers are investigating.

October 30, 2020 · 15:07 UTC

← Back