Latency Issues

Minor incident Crew App
2020-10-30 20:06 UTC · 14 hours, 4 minutes, 33 seconds

Updates

Resolved

Latency issues have been resolved and Crew is back to normal processing.

October 31, 2020 · 10:10 UTC
Issue

We are seeing latency issues within Command Center and the Crew Web App.

October 30, 2020 · 20:08 UTC

← Back