Crew is experiencing an issue sending and receiving messages.

Minor incident Crew App
2019-07-23 18:58 UTC · 13 minutes, 45 seconds

Updates

Resolved

The issue has been resolved and all service are back to normal.

July 23, 2019 · 19:12 UTC
Issue

We are investigating the issue with message sends and people not receiving messages.

July 23, 2019 · 18:59 UTC

← Back