Crew is experiencing a delay in sending and receiving messages.

Minor incident Crew App
2019-07-24 18:22 UTC · 14 minutes, 34 seconds

Updates

Resolved

The issue has been resolved and all service are back to normal.

July 24, 2019 · 18:36 UTC
Issue

We are investigating the issue with message sends and people not receiving messages.

July 24, 2019 · 18:27 UTC

← Back