Crew is experiencing a delay in sending and receiving messages

Minor incident Crew App
2021-03-24 15:24 UTC · 14 minutes, 19 seconds

Updates

Resolved

The issue has been resolved and all service are back to normal.

March 24, 2021 · 15:38 UTC
Issue

We are investigating the issue with message sends being delayed.

March 24, 2021 · 15:24 UTC

← Back