Crew is experiencing a delay in sending and receiving messages.

Minor incident Crew App
2021-04-21 13:52 UTC · 3 hours, 8 minutes, 22 seconds

Updates

Resolved

The issue has been resolved

April 22, 2021 · 17:01 UTC
Issue

We are investigating the issue with message sends and people not receiving messages and inability to connect.

April 21, 2021 · 14:01 UTC

← Back