Crew is experiencing an issue sending and receiving messages.

Major incident Crew App
2020-02-13 16:51 UTC · 7 hours, 33 minutes

Updates

Resolved

The updates we have made resolved the issues.

November 4, 2021 · 15:24 UTC
Monitoring

The root cause of the issue has been discovered and we are now monitoring an update that should resolve the issue.

November 4, 2021 · 15:24 UTC
Issue

We are investigating the issue with message sends and people not receiving messages.

November 4, 2021 · 15:24 UTC

← Back